Back to overview
Degraded

This issue is being looked into

Jan 25, 2024 at 10:01pm UTC

Resolved
Jan 25, 2024 at 10:03pm UTC

We've resolved this issue

Created
Jan 25, 2024 at 10:01pm UTC

We're currently looking into why the ping is so high for some users.