Back to overview
Downtime
We're currently looking into this
Jan 28 at 02:08pm CET
Resolved
Jan 28 at 05:01pm CET
We've applied a fix and it will be up within the next 5 minutes.
Affected services
Created
Jan 28 at 02:08pm CET
Our servers are currently under maintenance, we're getting them back up soon.
Affected services