Scheduled server maintenance and updates
Resolved
Mar 14, 2026 at 09:39pm UTC
Maintenance finished early.
Affected services
Updated
Mar 14, 2026 at 09:33pm UTC
Maintenance has started, please be advised that some services may be inaccessible during this time.
We estimate around 10 minutes. We have allowed 30 minutes just in case.
Affected services
Created
Mar 14, 2026 at 09:30pm UTC
We will be performing server updates to improve performance and stability. During this window, services may be temporarily unavailable. We appreciate your patience and will restore everything as quickly as possible.
Affected services